summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-26 08:48:08 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-26 08:48:08 +0100
commit4c6d5bd8cb0e59991695cfd0db389276aab3323f (patch)
treeed23e1b9bf6dc87a2255622255841e8d989ac2fb /dev-python/mistune/mistune-0.7.2.ebuild
parentdev-java/portletapi: Update SRC_URI. (diff)
downloadgentoo-4c6d5bd8cb0e59991695cfd0db389276aab3323f.tar.gz
gentoo-4c6d5bd8cb0e59991695cfd0db389276aab3323f.tar.bz2
gentoo-4c6d5bd8cb0e59991695cfd0db389276aab3323f.zip
dev-python/mistune: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/mistune/mistune-0.7.2.ebuild')
-rw-r--r--dev-python/mistune/mistune-0.7.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-0.7.2.ebuild b/dev-python/mistune/mistune-0.7.2.ebuild
new file mode 100644
index 000000000000..da82a552db8f
--- /dev/null
+++ b/dev-python/mistune/mistune-0.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.python.org/pypi/mistune https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}