summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-24 11:42:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-24 11:57:37 +0300
commit60bc57d8b6d6418449b978c2bb7b82adcdcfdc45 (patch)
treee804291d4f32c309b54e8459106fa82295bd16f9 /dev-python/mkdocs-git-authors-plugin
parentdev-util/rpmdevtools: add Python 3.10 support (diff)
downloadgentoo-60bc57d8b6d6418449b978c2bb7b82adcdcfdc45.tar.gz
gentoo-60bc57d8b6d6418449b978c2bb7b82adcdcfdc45.tar.bz2
gentoo-60bc57d8b6d6418449b978c2bb7b82adcdcfdc45.zip
dev-python/mkdocs-git-authors-plugin: drop 0.6.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index a43334a698a2..6b09e27caaab 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,3 +1,2 @@
-DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
DIST mkdocs-git-authors-plugin-0.6.3.tar.gz 27644 BLAKE2B a8778baeb504db5d0571aa20603e8d60e04d8c315c096b5b3f89bb6a3b433a11b04a510d7f80ae86a9bb54259c6a2b0f2e1cb5cdade4220d4dfa1f06612e4aea SHA512 ab1f6984da002b72af2a53131222a3ff7b6b50a7a57f5d1986bca9e7d34365eaa5bfdf7d920e4dbc555e332587607480eef4134d847faf866a3b4750db3747eb
DIST mkdocs-git-authors-plugin-0.6.4.tar.gz 27799 BLAKE2B 02456df969fac72fc29906ed6faa34ead8d04dcd005fdc39bf72393e5252934c398995cb07133107af99672328d03b96e9a19625a7a83ee438278cf4f8587f50 SHA512 948b59bed123acc4b02a01248b831ac27fd98a24653fbae315424a1da33573d109667ff8b836be454e7c9b56a6f68f45200effe8649fd4fe6d5551d1b93a6cd5
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild
deleted file mode 100644
index 5e3f4cc0b40d..000000000000
--- a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="dev-python/mkdocs-material"
-
-inherit distutils-r1 docs
-
-DESCRIPTION="Mkdocs plugin to display git authors of a page"
-HOMEPAGE="
- https://github.com/timvink/mkdocs-git-authors-plugin/
- https://pypi.org/project/mkdocs-git-authors-plugin/
-"
-SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/GitPython[${PYTHON_USEDEP}]
- >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/mkdocs-material[${PYTHON_USEDEP}]
- dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
- dev-vcs/git
- )
- doc? ( dev-vcs/git )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- # mkdocs-git-authors tests need git repo
- if use test || use doc; then
- git init -q || die
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git add . || die
- git commit -qm 'init' || die
- fi
-
- distutils-r1_python_prepare_all
-}