summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 11:19:53 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 12:12:19 +0100
commit7827bf1ca94eb96cf3914c2bb7881bc71331814e (patch)
treeb3edd5abaf8e22d38ac414dad59238bf4d1cd5ab /dev-python/mkdocs-git-authors-plugin
parentdev-python/mkdocs_pymdownx_material_extras: add version 1.6 (diff)
downloadgentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.tar.gz
gentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.tar.bz2
gentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.zip
dev-python/mkdocs-git-authors-plugin: add version 0.6.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 9a3ffcb3f1c9..a43334a698a2 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,2 +1,3 @@
DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
DIST mkdocs-git-authors-plugin-0.6.3.tar.gz 27644 BLAKE2B a8778baeb504db5d0571aa20603e8d60e04d8c315c096b5b3f89bb6a3b433a11b04a510d7f80ae86a9bb54259c6a2b0f2e1cb5cdade4220d4dfa1f06612e4aea SHA512 ab1f6984da002b72af2a53131222a3ff7b6b50a7a57f5d1986bca9e7d34365eaa5bfdf7d920e4dbc555e332587607480eef4134d847faf866a3b4750db3747eb
+DIST mkdocs-git-authors-plugin-0.6.4.tar.gz 27799 BLAKE2B 02456df969fac72fc29906ed6faa34ead8d04dcd005fdc39bf72393e5252934c398995cb07133107af99672328d03b96e9a19625a7a83ee438278cf4f8587f50 SHA512 948b59bed123acc4b02a01248b831ac27fd98a24653fbae315424a1da33573d109667ff8b836be454e7c9b56a6f68f45200effe8649fd4fe6d5551d1b93a6cd5
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
new file mode 100644
index 000000000000..9351c88694ad
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}