summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-14 02:30:09 +0000
committerSam James <sam@gentoo.org>2020-12-14 02:30:09 +0000
commit6817911f248f2fddb352f7e4844e3729a72dc552 (patch)
treed9a5b4f1ffff71dc62c362ce8e85adabb9c818dc /dev-python/mock/mock-4.0.3.ebuild
parentdev-libs/libusb: Revbump to fix Apple and USV device detection (diff)
downloadgentoo-6817911f248f2fddb352f7e4844e3729a72dc552.tar.gz
gentoo-6817911f248f2fddb352f7e4844e3729a72dc552.tar.bz2
gentoo-6817911f248f2fddb352f7e4844e3729a72dc552.zip
dev-python/mock: bump to 4.0.3
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/mock/mock-4.0.3.ebuild')
-rw-r--r--dev-python/mock/mock-4.0.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/mock/mock-4.0.3.ebuild b/dev-python/mock/mock-4.0.3.ebuild
new file mode 100644
index 000000000000..d658150ed21e
--- /dev/null
+++ b/dev-python/mock/mock-4.0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
+HOMEPAGE="https://github.com/testing-cabal/mock"
+SRC_URI="https://github.com/testing-cabal/mock/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/funcsigs[${PYTHON_USEDEP}]
+ ' -2)
+ >=dev-python/six-1.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e '/ pytest.*/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Upstream supports running tests only in their dream pristine
+ # environment. pytest doesn't work at all if mock is already
+ # installed. We can use plain unittest but we have to reinvent
+ # test filtering.
+ cp -r mock/tests "${BUILD_DIR}"/lib/mock/ || die
+ cd "${BUILD_DIR}"/lib || die
+ if ! python_is_python3; then
+ rm mock/tests/*py3* || die
+ fi
+
+ # https://github.com/testing-cabal/mock/commit/d6b42149bb87cf38729eef8a100c473f602ef7fa
+ if [[ ${EPYTHON} == pypy* ]]; then
+ sed -i -e 's:def test_copy:def _test_copy:' \
+ mock/tests/testmock.py || die
+ fi
+
+ # Avoid pytest dependency
+ sed -i -e '/import pytest/d' mock/tests/testhelpers.py || die
+
+ "${EPYTHON}" -m unittest discover -v || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG.rst README.rst )
+
+ distutils-r1_python_install_all
+}