summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/monotonic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/monotonic')
-rw-r--r--dev-python/monotonic/Manifest2
-rw-r--r--dev-python/monotonic/metadata.xml14
-rw-r--r--dev-python/monotonic/monotonic-0.2.ebuild20
-rw-r--r--dev-python/monotonic/monotonic-0.3.ebuild20
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/monotonic/Manifest b/dev-python/monotonic/Manifest
new file mode 100644
index 000000000000..213d31cddd69
--- /dev/null
+++ b/dev-python/monotonic/Manifest
@@ -0,0 +1,2 @@
+DIST monotonic-0.2.tar.gz 6652 SHA256 c5e81e875a43e218135ea2aa4c367523894e1a2d7633ddafbed5292c527644a8 SHA512 0da2f9504aebf1b046a06156e30b8d6b6fde29c642f442ba8e5a43336309fca0fe636488ea69e463fcba5951d990723fddc2b9172211f6d8c57b0ab3ebab1a66 WHIRLPOOL 129f6a170856780d727ff2ef11d4b3688971b7376c9e9f590c7bc85aa20ba35d699751ddd5de58d144d4a3d540a2aac7d3f9fd3a63d010d88d7f93ffa62c836c
+DIST monotonic-0.3.tar.gz 6707 SHA256 2825ba5ded67b1a70d44529634d3f4ddfad67a5ed7fdcf026022a3ce175be07b SHA512 772154934ffdd1a12aacc331761ce219980caac1bce243fd0740320a25152cf800142c5787c9423270bf02d18e88973dcd981781e2279b28ce364063102f1099 WHIRLPOOL 83d34eac5ee577ba8c42c6276d1c3a46fc30a63919ffd6f86260c09aaf6720ab171db89dfdaa28fd6d42ebb309725ff2e4e0e6c8306c21f9f12dce3d71436e71
diff --git a/dev-python/monotonic/metadata.xml b/dev-python/monotonic/metadata.xml
new file mode 100644
index 000000000000..04fc00a938e8
--- /dev/null
+++ b/dev-python/monotonic/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">monotonic</remote-id>
+ <remote-id type="github">atdt/monotonic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/monotonic/monotonic-0.2.ebuild b/dev-python/monotonic/monotonic-0.2.ebuild
new file mode 100644
index 000000000000..f469780ef414
--- /dev/null
+++ b/dev-python/monotonic/monotonic-0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/monotonic/monotonic-0.3.ebuild b/dev-python/monotonic/monotonic-0.3.ebuild
new file mode 100644
index 000000000000..f469780ef414
--- /dev/null
+++ b/dev-python/monotonic/monotonic-0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""