summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 10:14:47 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit5347877f80dd728c0b7007b0856037a88b093c4e (patch)
treeb7a1b303977889ae64259261156bc01744d84671 /dev-python/mox3
parentdev-python/monotonic: Add python3.5 support (diff)
downloadgentoo-5347877f80dd728c0b7007b0856037a88b093c4e.tar.gz
gentoo-5347877f80dd728c0b7007b0856037a88b093c4e.tar.bz2
gentoo-5347877f80dd728c0b7007b0856037a88b093c4e.zip
dev-python/mox3: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/mox3')
-rw-r--r--dev-python/mox3/mox3-0.7.0-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/mox3/mox3-0.7.0-r1.ebuild b/dev-python/mox3/mox3-0.7.0-r1.ebuild
index 55755bf0d843..ad24f08ae345 100644
--- a/dev-python/mox3/mox3-0.7.0-r1.ebuild
+++ b/dev-python/mox3/mox3-0.7.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-DISTUTILS_IN_SOURCE_BUILD=TRUE
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
@@ -48,6 +48,8 @@ RDEPEND="
${CRDEPEND}
"
+DISTUTILS_IN_SOURCE_BUILD=TRUE
+
python_test() {
# This single test fails on python3.4.
# I speculate this is due to the old style classes going away but have not