summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mox3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mox3')
-rw-r--r--dev-python/mox3/Manifest1
-rw-r--r--dev-python/mox3/metadata.xml8
-rw-r--r--dev-python/mox3/mox3-0.7.0-r1.ebuild67
-rw-r--r--dev-python/mox3/mox3-0.7.0.ebuild45
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/mox3/Manifest b/dev-python/mox3/Manifest
new file mode 100644
index 000000000000..60a8e5027dd4
--- /dev/null
+++ b/dev-python/mox3/Manifest
@@ -0,0 +1 @@
+DIST mox3-0.7.0.tar.gz 44073 SHA256 7cc2ffac72d55816bbf670b03cf636b4abdc089c3d8b31a6760b22fc1eeedde2 SHA512 ee4b87bad46fdb63e8988186846a1823fe9db512f1cd8cf37266db14413307824e45e38121bd16ca4c7f3753fbc051dfcd98dc5c9c9c933604b007ff1e7fea05 WHIRLPOOL 0c71c0ef8960ee535fa11a27855725601929ebd50ef56611c8aa8ac0bee500b63b3d63a60bb444511f2bc3b05bf65eb7d91821144d56da4e0da343ff3689d427
diff --git a/dev-python/mox3/metadata.xml b/dev-python/mox3/metadata.xml
new file mode 100644
index 000000000000..b1c2c7fd684e
--- /dev/null
+++ b/dev-python/mox3/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">mox3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mox3/mox3-0.7.0-r1.ebuild b/dev-python/mox3/mox3-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..55755bf0d843
--- /dev/null
+++ b/dev-python/mox3/mox3-0.7.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+DISTUTILS_IN_SOURCE_BUILD=TRUE
+
+inherit distutils-r1
+
+DESCRIPTION="Mock object framework for Python"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+CRDEPEND=">=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]"
+
+# NOTE dev-python/hacking isn't actually required for tests
+# >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+# <dev-python/hacking-0.7[${PYTHON_USEDEP}]
+
+# NOTE dev-python/pyflakes isn't actually required for tests
+# ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ ${CRDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${CRDEPEND}
+"
+
+python_test() {
+ # This single test fails on python3.4.
+ # I speculate this is due to the old style classes going away but have not
+ # verified this in any way.
+ if [[ "${EPYTHON}" = "python3.4" ]]; then
+ ebegin "patching mox3/tests/test_mox.py for ${EPYTHON}"
+ sed \
+ -e '/def testStubOutClass_OldStyle(self):/,/def/ d' \
+ -i mox3/tests/test_mox.py
+ STATUS=$?
+ eend $?
+ [[ ${STATUS} -gt 0 ]] && die
+ fi
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
diff --git a/dev-python/mox3/mox3-0.7.0.ebuild b/dev-python/mox3/mox3-0.7.0.ebuild
new file mode 100644
index 000000000000..2010ed8c813c
--- /dev/null
+++ b/dev-python/mox3/mox3-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# py2.6 capable but unrequired
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+# Use at your own risk ;), or because an openstack package cited it as a req'd dep :)
+DESCRIPTION="The Mock object framework for Python"
+HOMEPAGE="http://code.google.com/p/pymox/wiki/MoxDocumentation http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# Though test-req's cites hacking>=0.5.6,<0.7, setting to hacking>=0.7.2-r1,<0.8
+# since it WORKS and supports py3.2. What more do you want
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init || die
+ testr run || die "testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "flake8 drew error on a run over folder ${PN}/tests"
+}