summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-15 14:27:17 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-15 14:27:17 -0600
commitf7c4151ea7688f98cd9ac4763c90285e4053a23e (patch)
tree064f62658c0a2ebc1e5788544282ecba1817831c /dev-python/mox3
parentnet-mail/notmuch: Bump version to 0.21 (diff)
downloadgentoo-f7c4151ea7688f98cd9ac4763c90285e4053a23e.tar.gz
gentoo-f7c4151ea7688f98cd9ac4763c90285e4053a23e.tar.bz2
gentoo-f7c4151ea7688f98cd9ac4763c90285e4053a23e.zip
dev-python/mox3: add version 0.12.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/mox3')
-rw-r--r--dev-python/mox3/mox3-0.12.0.ebuild55
1 files changed, 20 insertions, 35 deletions
diff --git a/dev-python/mox3/mox3-0.12.0.ebuild b/dev-python/mox3/mox3-0.12.0.ebuild
index a5e5bbe16b66..76777e4002ff 100644
--- a/dev-python/mox3/mox3-0.12.0.ebuild
+++ b/dev-python/mox3/mox3-0.12.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mox3/mox3-0.7.0-r1.ebuild,v 1.3 2015/03/09 00:04:31 pacho Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-DISTUTILS_IN_SOURCE_BUILD=TRUE
+PYTHON_COMPAT=( python2_7 python3_4 )
inherit distutils-r1
@@ -14,39 +13,26 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
-CDEPEND="
- >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
-"
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
CRDEPEND=">=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]"
-
-# NOTE dev-python/hacking isn't actually required for tests
-# >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
-# <dev-python/hacking-0.7[${PYTHON_USEDEP}]
-
-# NOTE dev-python/pyflakes isn't actually required for tests
-# ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
-
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
${CRDEPEND}
- ~dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- ~dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
- >=dev-python/flake8-2.2.4[${PYTHON_USEDEP}]
- <=dev-python/flake8-2.4.1-r9999[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
<dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
)
"
RDEPEND="
@@ -54,20 +40,19 @@ RDEPEND="
${CRDEPEND}
"
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
python_test() {
- # This single test fails on python3.4.
- # I speculate this is due to the old style classes going away but have not
- # verified this in any way.
- if [[ "${EPYTHON}" = "python3.4" ]]; then
- ebegin "patching mox3/tests/test_mox.py for ${EPYTHON}"
- sed \
- -e '/def testStubOutClass_OldStyle(self):/,/def/ d' \
- -i mox3/tests/test_mox.py
- STATUS=$?
- eend $?
- [[ ${STATUS} -gt 0 ]] && die
- fi
+ rm -rf .testrepository || die "could not remove '.testrepository' under ${EPYTHON}"
testr init || die "testr init failed under ${EPYTHON}"
testr run || die "testr run failed under ${EPYTHON}"
}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}