summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-03-31 01:25:31 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-03-31 01:25:31 +0700
commitce87dab6c5be2a1c40b2f0ed6f4757df811c75f6 (patch)
treed504ce2e99fdc4bae7f8169cb86bb1cb2374527f /dev-python/mpmath
parentdev-python/mpmath: python3_6 added (diff)
downloadgentoo-ce87dab6c5be2a1c40b2f0ed6f4757df811c75f6.tar.gz
gentoo-ce87dab6c5be2a1c40b2f0ed6f4757df811c75f6.tar.bz2
gentoo-ce87dab6c5be2a1c40b2f0ed6f4757df811c75f6.zip
dev-python/mpmath: cleaning 0.19
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/mpmath-0.19.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/mpmath/mpmath-0.19.ebuild b/dev-python/mpmath/mpmath-0.19.ebuild
deleted file mode 100644
index 8002d1400bfa..000000000000
--- a/dev-python/mpmath/mpmath-0.19.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1 eutils
-
-MY_PN=${PN}-all
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://mpmath.org/"
-SRC_URI="http://mpmath.org/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples gmp matplotlib test"
-
-RDEPEND="
- gmp? ( dev-python/gmpy )
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}.patch"
- )
-
- # this fails with the current version of dev-python/py
- rm ${PN}/conftest.py || die
-
- # this test requires X
- rm ${PN}/tests/test_visualization.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd doc || die
- "${PYTHON}" build.py || die "Generation of documentation failed"
- fi
-}
-
-python_test() {
- py.test -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}