summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-13 10:14:23 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-13 10:23:18 -0500
commit72bbf21443ac6b8f553d8c73990ec3a0a1f98346 (patch)
tree5ad7c7637faadab7235f52263dc959bf4ee6210a /dev-python/multidict/multidict-2.0.1.ebuild
parentdev-ml/dose3: bump to 5.0.1 (diff)
downloadgentoo-72bbf21443ac6b8f553d8c73990ec3a0a1f98346.tar.gz
gentoo-72bbf21443ac6b8f553d8c73990ec3a0a1f98346.tar.bz2
gentoo-72bbf21443ac6b8f553d8c73990ec3a0a1f98346.zip
dev-python/multidict: add version 2.0.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/multidict/multidict-2.0.1.ebuild')
-rw-r--r--dev-python/multidict/multidict-2.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/multidict/multidict-2.0.1.ebuild b/dev-python/multidict/multidict-2.0.1.ebuild
new file mode 100644
index 000000000000..f43c16c699ce
--- /dev/null
+++ b/dev-python/multidict/multidict-2.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m pytest tests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}