summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 14:07:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 15:34:32 +0100
commit07b8b0f445b1000c15b35ada9c53bd8a2ffd857d (patch)
treebad6c6ecbd3ede1c775dc2179eaa44de79218249 /dev-python/multidict/multidict-5.1.0.ebuild
parentdev-db/slony1: Update Homepage (diff)
downloadgentoo-07b8b0f445b1000c15b35ada9c53bd8a2ffd857d.tar.gz
gentoo-07b8b0f445b1000c15b35ada9c53bd8a2ffd857d.tar.bz2
gentoo-07b8b0f445b1000c15b35ada9c53bd8a2ffd857d.zip
dev-python/multidict: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/multidict/multidict-5.1.0.ebuild')
-rw-r--r--dev-python/multidict/multidict-5.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/multidict/multidict-5.1.0.ebuild b/dev-python/multidict/multidict-5.1.0.ebuild
new file mode 100644
index 000000000000..1d0bc89295ad
--- /dev/null
+++ b/dev-python/multidict/multidict-5.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}