summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-08-26 13:24:41 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-08-26 13:24:41 -0700
commit323113cfe318ad10e9ca5e30056ac97a51ea3ada (patch)
treed04a6c652b2878d24795539158305d8a29392428 /dev-python/mypy_extensions
parentdev-python/typing-extensions-3.7.4.3: Version bump, add py39 (diff)
downloadgentoo-323113cfe318ad10e9ca5e30056ac97a51ea3ada.tar.gz
gentoo-323113cfe318ad10e9ca5e30056ac97a51ea3ada.tar.bz2
gentoo-323113cfe318ad10e9ca5e30056ac97a51ea3ada.zip
dev-python/mypy_extensions-0.4.3-r1: Revbump, EAPI=7 add py39 and pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/mypy_extensions')
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..60db648be0fe
--- /dev/null
+++ b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/python/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ "${PV}" =~ [9]{4,} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/python/${PN}"
+ EGIT_COMMIT="master"
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ dev-python/sphinx \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ "${PYTHON}" -m unittest discover tests -v || die "tests fail with ${EPYTHON}"
+}