summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-04 09:32:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-04 09:32:28 +0100
commit5d13e2607372c0ab379eea1ba2631d7bbc985a03 (patch)
tree33403d8ef813c34807f6b62fcd9707b831d924c1 /dev-python/myst_parser/myst_parser-0.18.0.ebuild
parentdev-python/cattrs: Remove old (diff)
downloadgentoo-5d13e2607372c0ab379eea1ba2631d7bbc985a03.tar.gz
gentoo-5d13e2607372c0ab379eea1ba2631d7bbc985a03.tar.bz2
gentoo-5d13e2607372c0ab379eea1ba2631d7bbc985a03.zip
dev-python/myst_parser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/myst_parser/myst_parser-0.18.0.ebuild')
-rw-r--r--dev-python/myst_parser/myst_parser-0.18.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/myst_parser/myst_parser-0.18.0.ebuild b/dev-python/myst_parser/myst_parser-0.18.0.ebuild
deleted file mode 100644
index 7217c0a65cc4..000000000000
--- a/dev-python/myst_parser/myst_parser-0.18.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=MyST-Parser-${PV}
-DESCRIPTION="Extended commonmark compliant parser, with bridges to sphinx"
-HOMEPAGE="
- https://github.com/executablebooks/MyST-Parser/
- https://pypi.org/project/myst-parser/
-"
-SRC_URI="
- https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- <dev-python/docutils-0.19[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markdown-it-py[${PYTHON_USEDEP}]
- dev-python/mdit-py-plugins[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- <dev-python/sphinx-6[${PYTHON_USEDEP}]
- >=dev-python/sphinx-4[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/pytest-regressions[${PYTHON_USEDEP}]
- dev-python/pytest-param-files[${PYTHON_USEDEP}]
- dev-python/sphinx-pytest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Unimportant tests needing a new dep linkify
- tests/test_renderers/test_myst_config.py::test_cmdline
- tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # bad test relying on exact exception messages
- "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
- )
-
- epytest
-}