summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-09 19:22:56 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-09 20:43:14 +0200
commit619be1feaa18eb694ff4c4223538c83f254f093e (patch)
treeee0a5ae4099fbb3c658b28b578d0c8fc58dee1d5 /dev-python/namespace-paste
parentdev-python/namespace-repoze: Fix whitespace (diff)
downloadgentoo-619be1feaa18eb694ff4c4223538c83f254f093e.tar.gz
gentoo-619be1feaa18eb694ff4c4223538c83f254f093e.tar.bz2
gentoo-619be1feaa18eb694ff4c4223538c83f254f093e.zip
dev-python/namespace-paste: Namespace package for paste.*
Diffstat (limited to 'dev-python/namespace-paste')
-rw-r--r--dev-python/namespace-paste/metadata.xml7
-rw-r--r--dev-python/namespace-paste/namespace-paste-1.ebuild33
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/namespace-paste/metadata.xml b/dev-python/namespace-paste/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/namespace-paste/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/namespace-paste/namespace-paste-1.ebuild b/dev-python/namespace-paste/namespace-paste-1.ebuild
new file mode 100644
index 000000000000..760dcb9e090b
--- /dev/null
+++ b/dev-python/namespace-paste/namespace-paste-1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-r1
+
+DESCRIPTION="Namespace package declaration for paste"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_unpack() {
+ mkdir -p "${S}"/paste || die
+ cat > "${S}"/paste/__init__.py <<-EOF || die
+ __import__('pkg_resources').declare_namespace(__name__)
+ EOF
+}
+
+src_install() {
+ python_foreach_impl python_domodule paste
+}