summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 17:07:45 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 17:20:06 +0300
commit7fd18acee9712cd4fa02f39dffc8f9e1e7af2256 (patch)
treee0a12268b5736191ada6ea5dda1564668ec08d77 /dev-python/namespace-paste
parentdev-python/pyquery: py3_7 + eapi7 (diff)
downloadgentoo-7fd18acee9712cd4fa02f39dffc8f9e1e7af2256.tar.gz
gentoo-7fd18acee9712cd4fa02f39dffc8f9e1e7af2256.tar.bz2
gentoo-7fd18acee9712cd4fa02f39dffc8f9e1e7af2256.zip
dev-python/namespace-paste: eapi7 + py3_7
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/namespace-paste')
-rw-r--r--dev-python/namespace-paste/namespace-paste-1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/namespace-paste/namespace-paste-1-r1.ebuild b/dev-python/namespace-paste/namespace-paste-1-r1.ebuild
new file mode 100644
index 000000000000..8fe4d7da6cfe
--- /dev/null
+++ b/dev-python/namespace-paste/namespace-paste-1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit python-r1
+
+DESCRIPTION="Namespace package declaration for paste"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_unpack() {
+ mkdir -p "${S}"/paste || die
+ cat > "${S}"/paste/__init__.py <<-EOF || die
+ __import__('pkg_resources').declare_namespace(__name__)
+ EOF
+}
+
+src_install() {
+ python_foreach_impl python_domodule paste
+}