summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-17 09:08:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-17 09:28:54 +0200
commit0e85c1f11221a41fbbdea9278bc1ca34bf120fa9 (patch)
tree3f8f799c70c19745ec2120af7658aa1f7c2e3f0e /dev-python/nbclient
parentdev-python/hcloud-python: Bump to 1.15.0 (diff)
downloadgentoo-0e85c1f11221a41fbbdea9278bc1ca34bf120fa9.tar.gz
gentoo-0e85c1f11221a41fbbdea9278bc1ca34bf120fa9.tar.bz2
gentoo-0e85c1f11221a41fbbdea9278bc1ca34bf120fa9.zip
dev-python/nbclient: Bump to 0.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.5.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 39c05de7fa8a..a47e36e4c1df 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1 +1,2 @@
DIST nbclient-0.5.3.gh.tar.gz 69340 BLAKE2B ef2908037b350879b4494a9676550754b51c218c0b344c8f26882fac63d3de65b37329fc8aa586f71f0fcb24d0508c2aec81d1066021abd4c66ee1b220574ef8 SHA512 16a92bdab931c2cec133389bfd491c9f3f4ca7ff3b11a3eb70fcdb568a0aecb8cca65d5a1fb25ff9a6ed6d581bed04de8e51ac2d856fad386b22aa6a2424c991
+DIST nbclient-0.5.4.gh.tar.gz 69711 BLAKE2B d229cf7a20df622f87984460735a6817d8bc50243b2980b2a14ce84b4f9b97336cc9fd0d4259cfa6700279eb555debf1a0bb57d9d28d78447e6a227097b77feb SHA512 1dcee18a13f143f4a688ed1d9baaca91b1753bfabac9ea97eadfa4a96fc8cd6462f471645da586a3c5c4b03550cbf5948c7320a26a299807ae09cc823cd7ff86
diff --git a/dev-python/nbclient/nbclient-0.5.4.ebuild b/dev-python/nbclient/nbclient-0.5.4.ebuild
new file mode 100644
index 000000000000..4685a1d6d809
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.5.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest