summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-12-16 10:23:05 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 12:14:47 +0200
commitd9ddbcefb26170570187ee9ec602c5a927b088a0 (patch)
tree300461d9707dde00270ce5ee30bc13d93d674fb9 /dev-python/nbconvert/nbconvert-4.3.0.ebuild
parentmedia-video/griffith: remove unused patch (diff)
downloadgentoo-d9ddbcefb26170570187ee9ec602c5a927b088a0.tar.gz
gentoo-d9ddbcefb26170570187ee9ec602c5a927b088a0.tar.bz2
gentoo-d9ddbcefb26170570187ee9ec602c5a927b088a0.zip
dev-python/nbconvert: Version bump to 4.3.0
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3131
Diffstat (limited to 'dev-python/nbconvert/nbconvert-4.3.0.ebuild')
-rw-r--r--dev-python/nbconvert/nbconvert-4.3.0.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/nbconvert/nbconvert-4.3.0.ebuild b/dev-python/nbconvert/nbconvert-4.3.0.ebuild
new file mode 100644
index 000000000000..4419c716443f
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-4.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/mistune[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
+ app-text/pandoc
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test --cov nbconvert -v --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}