summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:51:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:18 +0100
commit4208fe952e9915022c6b1c383f6b85412d9d7e51 (patch)
tree2a62f72b5691b707dc03ba6838b12ea97f9781ba /dev-python/nbconvert
parentdev-python/paramiko: Bump to 2.10.1 (diff)
downloadgentoo-4208fe952e9915022c6b1c383f6b85412d9d7e51.tar.gz
gentoo-4208fe952e9915022c6b1c383f6b85412d9d7e51.tar.bz2
gentoo-4208fe952e9915022c6b1c383f6b85412d9d7e51.zip
dev-python/nbconvert: Bump to 6.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-6.4.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index ae3a4edfa570..cd4da69df035 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1 +1,2 @@
DIST nbconvert-6.4.2.tar.gz 902691 BLAKE2B ee61836ac423db0803d90b92f5cfce7e53e311637dfff7e31e5506fc1588a41515e984860bc56f617b0e0add033c41e6d2099f2abfdda7f31015f6e751110639 SHA512 325637844044ff4a118ca7803e9803fd6909667e017dae04859f58a02e1aadc8b8c699f9b9612bd47991a4c06a23acd526abdcbf1a219e29d985001ae01237bb
+DIST nbconvert-6.4.4.tar.gz 906988 BLAKE2B 84ea6726804ccb738995df1e2e961a9816d3bf9c77034d464afbfa2ba0cf3ce19c1f6af1775fa027795ba3faeaacac765decce2d309f8a60a27e76934cdb356a SHA512 2b319fcc13c6b2addc7e1ca319f36e8a37e8390eb0d8d8df9f9456e7ae816b93ec30ab00a1003894c92091030658920729f0e31fdb5031dccb3f36b38b5d8f99
diff --git a/dev-python/nbconvert/nbconvert-6.4.4.ebuild b/dev-python/nbconvert/nbconvert-6.4.4.ebuild
new file mode 100644
index 000000000000..e67490b889a2
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-6.4.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="https://nbconvert.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/mistune-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/mistune-2[${PYTHON_USEDEP}]
+ dev-python/nbclient[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ mkdir -p "${HOME}/.local" || die
+ cp -r share "${HOME}/.local/" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ nbconvert/exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ )
+
+ epytest --pyargs nbconvert
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}