summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-03 22:57:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-03 23:21:08 +0200
commit6abb9e0d45aea487498a13f16b1a4c54625c058a (patch)
treee944d8ef7ca080bf0ed136b96fe5ffcc3597b50e /dev-python/nbconvert
parentdev-python/loky: Bump to 2.9.0 (diff)
downloadgentoo-6abb9e0d45aea487498a13f16b1a4c54625c058a.tar.gz
gentoo-6abb9e0d45aea487498a13f16b1a4c54625c058a.tar.bz2
gentoo-6abb9e0d45aea487498a13f16b1a4c54625c058a.zip
dev-python/nbconvert: Bump to 6.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-6.0.7.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 3809b6a6622f..ecf7bbc3ada6 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -3,3 +3,4 @@ DIST nbconvert-6.0.3.tar.gz 848214 BLAKE2B 4265486536cfe0cf220b8080374726cc68be4
DIST nbconvert-6.0.4.tar.gz 841651 BLAKE2B 080f60103709bd6ddb8258750a51e7bf8891adb1eb2921619cfbb0e774a585f3d3722758d8895f67a76e2705a15a0b35ffcb7c59842ec986a13315e5b10f4eca SHA512 46c2d250e25ad0e2fee0be0fefacc198687acd7ffcb4205bb8cf0ed263e90878cf659f352d551911b0025cb150302ea9ffd67b9453ec23fc5821908f7b56dd75
DIST nbconvert-6.0.5.tar.gz 841650 BLAKE2B 7f8bb3849374284c90bd7b17c27a313c69694e42d4fd7b5913d3b210a15f17b89ffca8436ce31fa5bfc2b586feb536522106522f3d1741ad0fb6c2995a2e562e SHA512 79164546164eada6998bd6898833dfbada0a1476af8796bea40794f6caf121d0b9560f0f50e3d477357e977222a3b75f3de85ccfa03c4aec93be75801cf6f97c
DIST nbconvert-6.0.6.tar.gz 888348 BLAKE2B 7662437e1436a4ee9694bc05b8472b64d0773c38cc5fda3372ce9009f5d6d20e2ffb28c4baf3442cbc88414ce97870cf15a102ee609f4aae2c951d3f7ac5202f SHA512 2be6a65ed86dd10fc4fd08536db304dc359da1af66c4f907753a419b8d9caec08274c07d110a060bdae5626bb48a4f6d209e423b8eacee420d3a4c6ef0f6bbf5
+DIST nbconvert-6.0.7.tar.gz 896833 BLAKE2B 1b5b39144509aa9f61dc1e9675b112d69ed2e2f9859f3ce7ccfac517d89fff0010062c03ded1c3db571c84dd8d4f8ba12e4851245f370d2e671d24921dd50ab6 SHA512 3c78fa4d777a79a08606a39bb31f6b329dc9d28c1ef2ea9f3253746dce853a295e8fe85b14c65b04762aa5acd5facc879232a375875a2ca6dc9477cc1ab88786
diff --git a/dev-python/nbconvert/nbconvert-6.0.7.ebuild b/dev-python/nbconvert/nbconvert-6.0.7.ebuild
new file mode 100644
index 000000000000..58b0853ec91c
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-6.0.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="https://nbconvert.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/mistune-0.7.4[${PYTHON_USEDEP}]
+ dev-python/nbclient[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pebble[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.2[${PYTHON_USEDEP}]
+ media-gfx/inkscape
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ mkdir -p "${HOME}/.local" || die
+ cp -r share "${HOME}/.local/" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local deselect=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ --deselect exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ --deselect 'tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ )
+
+ distutils_install_for_testing bdist_egg
+ cd "${TEST_DIR}"/lib || die
+ pytest -vv "${deselect[@]}" --pyargs nbconvert || die "Tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}