summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:09:19 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:09:19 +0100
commit8cf4abdaf3fafeb17997e1403172607e4791e76a (patch)
tree542f07ea6ae82aed16cdce788325bcf166ad1d46 /dev-python/nbformat
parentdev-python/jupyter_core: Import from science overlay (diff)
downloadgentoo-8cf4abdaf3fafeb17997e1403172607e4791e76a.tar.gz
gentoo-8cf4abdaf3fafeb17997e1403172607e4791e76a.tar.bz2
gentoo-8cf4abdaf3fafeb17997e1403172607e4791e76a.zip
dev-python/nbformat: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/metadata.xml15
-rw-r--r--dev-python/nbformat/nbformat-4.0.1.ebuild60
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
new file mode 100644
index 000000000000..f866283e2153
--- /dev/null
+++ b/dev-python/nbformat/Manifest
@@ -0,0 +1 @@
+DIST nbformat-4.0.1.tar.gz 105767 SHA256 5261c957589b9dfcd387c338d59375162ba9ca82c69e378961a1f4e641285db5 SHA512 f73e8cffc61825aa8b7b0ef3b842cba51baf2cdf0c5d0035e2e7cb51f71c6c819f09201367a3b342c2736492dee1e78c519961aaea8f2cc4b5e69a1545085d2a WHIRLPOOL 9b08003c456e00c529b7bf8e786d57a583e53e5a1e7e9eb4c3cc492c5b1d60e76579c9102e6c56749d546a9a124d475687d4ec1d71e0f3634698d5e30499db93
diff --git a/dev-python/nbformat/metadata.xml b/dev-python/nbformat/metadata.xml
new file mode 100644
index 000000000000..cf2dd6b8fd9d
--- /dev/null
+++ b/dev-python/nbformat/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Jupyther nbformat contains the reference implementation of the
+ Jupyter Notebook format, and Python APIs for working with
+ notebooks. There is also a JSON schema for notebook format
+ versions &gt;= 3.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nbformat</remote-id>
+ <remote-id type="github">jupyter/nbformat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nbformat/nbformat-4.0.1.ebuild b/dev-python/nbformat/nbformat-4.0.1.ebuild
new file mode 100644
index 000000000000..449d99c5baba
--- /dev/null
+++ b/dev-python/nbformat/nbformat-4.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests --with-coverage --cover-package=nbformat nbformat || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}