summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 08:05:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 08:35:02 +0100
commitb5275bb0d438e1ad2bf1d48fb0f98274f6a519e8 (patch)
treef5ca7cf4b1dcc3228e0e7c229376e418fa9d6235 /dev-python/nbformat
parentdev-util/debugedit: Remove old (diff)
downloadgentoo-b5275bb0d438e1ad2bf1d48fb0f98274f6a519e8.tar.gz
gentoo-b5275bb0d438e1ad2bf1d48fb0f98274f6a519e8.tar.bz2
gentoo-b5275bb0d438e1ad2bf1d48fb0f98274f6a519e8.zip
dev-python/nbformat: Bump to 5.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index c02d36115bf5..759103f83a54 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,3 +1,4 @@
DIST nbformat-5.0.8.gh.tar.gz 127329 BLAKE2B 6252d35f72fd0af5a89d83e9e48f61baf2656eb6530d4a7b05a5241e7272098992d70d68705da4fb9921ab1939378658b2e6e5f765a453f932e94e9232006a66 SHA512 956add98517f1128d8efacae1f3cf9fe27b4d7acae4a56e14dd6c2942aab39b063170759bc6de67bcedd2e0fd6c7ab1a36aef268f2088644ba31caa936b9359d
DIST nbformat-5.1.0.gh.tar.gz 152052 BLAKE2B 571d48af8c92b1cff9110935e00f53543d7bbae5ed9a08b516e9ff23366d9db7e4b1fb50dc786f2cd70d7f871baa05b6be86a6f22940724d90d05fdf58449bba SHA512 17c234e7777c170d629c0d3a4d8d7ddf01a754977a5e21357550ff702c5b4e26cd31164b32ced0fb20f3c0953390efd9a7509ed92f6c159fcef8634bd3f6af53
DIST nbformat-5.1.1.gh.tar.gz 152242 BLAKE2B df5e293ab235156f78e2bf85f1a22e597d8e0a60a6e448c69d4e04b62eed834b078238ad03a67e58ee0f705d1495b2f6c4b42124b8d439adbcb52be7ee91ae36 SHA512 5058c009b5148e6764de942cc43cb4774abad758250f065f9103c94f820de841b72d0f69ad24c38ade0c9fca3df61b7ea51b6097c6c191a2f606d57ef358083f
+DIST nbformat-5.1.2.gh.tar.gz 152275 BLAKE2B 2a0758f33952547e5ef91f0ac0a8b98b97b882a8797c38feff6710a3a0824637f41396b152403e155e1af9805b7a85c189ba2a609076c591562e5f4bb783da29 SHA512 4fd574373c2f325b6d078a062878d139d741d30f9101f3344e0c7fc19bdf714f8ef71994134e76c90e1301102aac55cc490df8344f3ceb407002437f35d03944
diff --git a/dev-python/nbformat/nbformat-5.1.2.ebuild b/dev-python/nbformat/nbformat-5.1.2.ebuild
new file mode 100644
index 000000000000..6991991c0a60
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+# missing on pypi
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest