summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-14 18:29:13 -0800
committerDavid Seifert <soap@gentoo.org>2017-01-04 14:34:28 +0200
commit45b1d6ba73b1791513a0e22396022a8278e5d7c1 (patch)
tree72b15689e4202a54163b990d13920ffe47e80a0b /dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild
parentdev-tex/latexdiff: add missing dep on dev-texlive/texlive-genericrecommended,... (diff)
downloadgentoo-45b1d6ba73b1791513a0e22396022a8278e5d7c1.tar.gz
gentoo-45b1d6ba73b1791513a0e22396022a8278e5d7c1.tar.bz2
gentoo-45b1d6ba73b1791513a0e22396022a8278e5d7c1.zip
dev-python/neovim-python-client: Bump to 0.1.12
Closes: https://github.com/gentoo/gentoo/pull/3124
Diffstat (limited to 'dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild')
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild
new file mode 100644
index 000000000000..67a411bb77c1
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.1.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="https://github.com/neovim/python-client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
+"
+
+RDEPEND="
+ ${DEPEND}
+ >=app-editors/neovim-0.1.6
+"
+
+S="${WORKDIR}/python-client-${PV}"