summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/neovim-python-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/neovim-python-client')
-rw-r--r--dev-python/neovim-python-client/Manifest1
-rw-r--r--dev-python/neovim-python-client/metadata.xml9
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.0.37.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/Manifest b/dev-python/neovim-python-client/Manifest
new file mode 100644
index 000000000000..844f2826257b
--- /dev/null
+++ b/dev-python/neovim-python-client/Manifest
@@ -0,0 +1 @@
+DIST neovim-python-client-0.0.37.tar.xz 38008 SHA256 615120048e0bac403fe85dd9bc74a5b2fe92cc9d1dc7c65f92f8a2bf361e0ec9 SHA512 23c3557564a16f9d1c4561d6ebb6d546d52c1cdc0216f36e77edf4567f7143f30e6832296324a3897a1eb38992973c63f99c373d88e330650cd8de6e4ba665cd WHIRLPOOL d0099e8f149eea2b115129b226253d848aa1b5be2685bab5eff6cd2fa5c5c5d0de6f070ed2fca860d9bc8105a139bbb6bb9d7a4f02baef1bf337d13046803463
diff --git a/dev-python/neovim-python-client/metadata.xml b/dev-python/neovim-python-client/metadata.xml
new file mode 100644
index 000000000000..804596a47144
--- /dev/null
+++ b/dev-python/neovim-python-client/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">neovim/python-client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.0.37.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.0.37.ebuild
new file mode 100644
index 000000000000..68eec917998f
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.0.37.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python client to connect to Neovim thru its msgpack-rpc API"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+REQUIRED_USE="gtk? ( python_targets_python2_7 )" # experimental gui only works with py2
+
+DEPEND=">=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/greenlet[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+ gtk? ( >=dev-python/click-3.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ x11-libs/gtk+:2[introspection] )"
+RDEPEND="${DEPEND}"