summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-12 08:55:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-12 10:16:55 +0100
commit58735154262d4d4029be44b641b595386211dcf0 (patch)
treecb15218b821c7bbf45238accf88ea7562aa132f7 /dev-python/nest_asyncio
parentdev-python/cmd2: Bump to 1.4.0 (diff)
downloadgentoo-58735154262d4d4029be44b641b595386211dcf0.tar.gz
gentoo-58735154262d4d4029be44b641b595386211dcf0.tar.bz2
gentoo-58735154262d4d4029be44b641b595386211dcf0.zip
dev-python/nest_asyncio: Bump to 1.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nest_asyncio')
-rw-r--r--dev-python/nest_asyncio/Manifest1
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.4.3.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index 92f7ca6a9c02..c7846cd7b19f 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1,2 +1,3 @@
DIST nest_asyncio-1.4.0.tar.gz 7053 BLAKE2B e9bdfa53f8a94ddbfd87b638962b5281aa3e8830c75a019d66d8275eb107aa7268d7f5aa24782d648a5fcfbfc4e1040abf2f2f0ca5678a513a95111d293eb055 SHA512 6a5130938baabafba30c4d5435276d33aa5df5e52a84e5646de55ab64bc01d3b69340b725b74dbe3dd158d5fba8db1470a322bdcdc3b75aa1a121076e3553a06
DIST nest_asyncio-1.4.2.tar.gz 5991 BLAKE2B 8a7feba9d506002ffa6658188fc1a20e2ac55f6661c2be37be678c6930e906235cdd94b5e359428555d8b9400a810a3483e07b3118b49757464fb9e8195a4cdf SHA512 00581b5dbecd085f2f4534dceb04b894973939c6e209bfae1f4b13b5c608bcf403f590af9694c6973e06dc325a5c7b8dc278f8b83eb5ca125a96074e0046984e
+DIST nest_asyncio-1.4.3.tar.gz 5996 BLAKE2B 399086236427fca6073b95ee898c9bb9ebbc984e36219b9f5bdcaff4d670a51985e1e3ca7597faf8b20ea3cb1610f5ad3fc12a30fe2207dadcd7d784c50679a7 SHA512 8d8e3384238c685211f4ae4e3a5c2d6bb0712880abe71b25287eabaee19deb3d669e6e4f2eead3d76825b460025e0cc4f8dc04197d140503b32563142c4ab596
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.4.3.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.4.3.ebuild
new file mode 100644
index 000000000000..59e0ec644321
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.4.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests setup.py