summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-12 02:38:09 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-12 03:36:07 +0200
commit9dcfb7e4be96de33b0997fae3e74e561661185d7 (patch)
tree2c2c64d4bbb4f14e4a4c94c9278af7f40f1babf4 /dev-python/netaddr/netaddr-0.8.0.ebuild
parentdev-python/netaddr: add python@g.o to maintainers + upstream info (diff)
downloadgentoo-9dcfb7e4be96de33b0997fae3e74e561661185d7.tar.gz
gentoo-9dcfb7e4be96de33b0997fae3e74e561661185d7.tar.bz2
gentoo-9dcfb7e4be96de33b0997fae3e74e561661185d7.zip
dev-python/netaddr: bump to 0.8.0+EAPI 7, support Py3.8+3.9, add doc
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/netaddr/netaddr-0.8.0.ebuild')
-rw-r--r--dev-python/netaddr/netaddr-0.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/netaddr/netaddr-0.8.0.ebuild b/dev-python/netaddr/netaddr-0.8.0.ebuild
new file mode 100644
index 000000000000..cdd931175b5e
--- /dev/null
+++ b/dev-python/netaddr/netaddr-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Network address representation and manipulation library"
+HOMEPAGE="https://github.com/drkjam/netaddr https://pypi.org/project/netaddr/ https://netaddr.readthedocs.org"
+# The next release should have docs in the PyPI tarball
+# https://github.com/netaddr/netaddr/commit/e6f545fccd83dbd14baff40070594cc96838c9bf
+SRC_URI="https://github.com/netaddr/netaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cli"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+ cli? (
+ >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Disable coverage (requires additional plugins)
+ sed -i 's/^addopts = .*//' pytest.ini || die
+ distutils-r1_src_prepare
+}