summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 07:38:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:14:49 +0200
commit046883e369a0d5f93ce35d57950d39c00280d1e1 (patch)
tree9fda0a2ad173310865292a87c5d4e5281085f3e4 /dev-python/networkx
parentdev-python/setuptools: Bump to 62.3.2 (diff)
downloadgentoo-046883e369a0d5f93ce35d57950d39c00280d1e1.tar.gz
gentoo-046883e369a0d5f93ce35d57950d39c00280d1e1.tar.bz2
gentoo-046883e369a0d5f93ce35d57950d39c00280d1e1.zip
dev-python/networkx: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.8.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 6811d131b64c..3e6cc5259884 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
+DIST networkx-2.8.1.tar.gz 1945388 BLAKE2B 5c7ee6826f952d6f834d88ab0ba82d11d8a171611f43750d8d64ca6adf428fb64e8c37ca9c03654941c6d67eb8b68710e4e923f008c99d724ad47d42c31dc75d SHA512 a85b6be14aabb4f4d5317f65fca1d681d93bb6defdb81c4fe59b06e9632816adaa322ae7e8f2277a78290f0ac6260438b503c79d4cbb39fcd37562e8325d89d3
DIST networkx-2.8.tar.gz 1937426 BLAKE2B 5a094177ed480c6f7cbdacb6795fc4f2e0aec53ed89a33e19d78f47830d46238f35b7cd76098f6e00397f7cbdf305256910b7930cbb2c775ed4c2b18d9bd596f SHA512 72cd6637faa4228f6c802cf36935b5460fdf9b6cf191c3b375810bfc3732823e3286bdc1e6cbf7e6a7ffde83d0cf3bca157ae27ff98c537d43fdb4b8ef45ef4b
diff --git a/dev-python/networkx/networkx-2.8.1.ebuild b/dev-python/networkx/networkx-2.8.1.ebuild
new file mode 100644
index 000000000000..a25ddcc29820
--- /dev/null
+++ b/dev-python/networkx/networkx-2.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # virtx implies nonfatal
+ nonfatal epytest -p no:django || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "dev-python/gdal"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}