summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-10 08:17:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-10 09:14:46 +0200
commit6836eecfff3439548a81144da8f09521df8fd572 (patch)
tree95300f922ecf1fdfe7e88217ff4f48c2abf5c2c6 /dev-python/networkx
parentdev-python/hypothesis: Bump to 6.20.1 (diff)
downloadgentoo-6836eecfff3439548a81144da8f09521df8fd572.tar.gz
gentoo-6836eecfff3439548a81144da8f09521df8fd572.tar.bz2
gentoo-6836eecfff3439548a81144da8f09521df8fd572.zip
dev-python/networkx: Bump to 2.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-2.6.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 47bf2b6c4ca2..a6f60fdd3f54 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
DIST networkx-2.6.2.tar.gz 1842077 BLAKE2B 8493e2d6a64d140b012ea443e9b1dc2409f8208dc1678c1d21cfd19bbdc07df6e9051aefe994d5fa6460db48320d563bb3051150782545ab5f671b7aafda4d0a SHA512 7006dcd209cce79f0f6cac4884797775422bd90fd3e8abb2eee70e6e00c9a25a785dd5856fc1657019a2b5c13a6fa5f705ea2e650c15a1f9d7d93580bc299219
+DIST networkx-2.6.3.tar.gz 1844862 BLAKE2B 408f97e334c3e0cec6d40d15d6ba8dc3c07cbd162fb31b301696c53ff1d924fd12f60d34df3f1b56fd036f2a344933a3b5c41a1aa2f91e5d5ca39f922cdfc41b SHA512 709b5126039c4b34a9b2ed60723e8bab3f591203f3ae8d87474e0f49f52b94b9c15568c78cc9e05e2bf997bc65a6177762bc41b0a44093ee59f6eaa0087d0f34
diff --git a/dev-python/networkx/networkx-2.6.3.ebuild b/dev-python/networkx/networkx-2.6.3.ebuild
new file mode 100644
index 000000000000..51a49fc1b85c
--- /dev/null
+++ b/dev-python/networkx/networkx-2.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="https://networkx.org/ https://github.com/networkx/networkx"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples extras xml yaml"
+
+RDEPEND="
+ >=dev-python/matplotlib-3.3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
+ extras? (
+ >=dev-python/pydot-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pygraphviz-1.7[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+ xml? ( >=dev-python/lxml-4.5[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ virtx epytest -p no:django ${deselect[@]/#/--deselect }
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}