summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-29 16:55:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-29 16:58:11 +0000
commit59e27bc47bcd5037fda6979fd7f19a94c609060c (patch)
tree301fac944ca0e7b423c9212801c443bccb9ed05f /dev-python/nltk/nltk-3.2.5.ebuild
parentdev-python/pysolr: Bump (diff)
downloadgentoo-59e27bc47bcd5037fda6979fd7f19a94c609060c.tar.gz
gentoo-59e27bc47bcd5037fda6979fd7f19a94c609060c.tar.bz2
gentoo-59e27bc47bcd5037fda6979fd7f19a94c609060c.zip
dev-python/nltk: Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/nltk/nltk-3.2.5.ebuild')
-rw-r--r--dev-python/nltk/nltk-3.2.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/nltk/nltk-3.2.5.ebuild b/dev-python/nltk/nltk-3.2.5.ebuild
new file mode 100644
index 000000000000..00df16dee538
--- /dev/null
+++ b/dev-python/nltk/nltk-3.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy test tk"
+
+RDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# currently requires linguistic data to be downloaded separately
+RESTRICT="test"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}