summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-04-12 08:10:49 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-04-12 08:10:49 +0200
commit58acc72bfe290a87fb5675d003c78f589554229d (patch)
tree8a9373fab066b5d2472c87cc19bbc25fcd974208 /dev-python/nodeenv/nodeenv-1.6.0.ebuild
parentdev-ruby/ethon: add 0.13.0 (diff)
downloadgentoo-58acc72bfe290a87fb5675d003c78f589554229d.tar.gz
gentoo-58acc72bfe290a87fb5675d003c78f589554229d.tar.bz2
gentoo-58acc72bfe290a87fb5675d003c78f589554229d.zip
dev-python/nodeenv: add 1.6.0
Closes: https://bugs.gentoo.org/781911 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/nodeenv/nodeenv-1.6.0.ebuild')
-rw-r--r--dev-python/nodeenv/nodeenv-1.6.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/nodeenv/nodeenv-1.6.0.ebuild b/dev-python/nodeenv/nodeenv-1.6.0.ebuild
new file mode 100644
index 000000000000..609da67f424b
--- /dev/null
+++ b/dev-python/nodeenv/nodeenv-1.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Node.js virtual environment builder"
+HOMEPAGE="https://github.com/ekalinin/nodeenv"
+SRC_URI="https://github.com/ekalinin/nodeenv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# requires network access
+RESTRICT="test"