summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-16 09:53:07 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-16 10:53:42 +0200
commit366587f522f9158cd7612877d42a807087b2fe1c (patch)
tree0c1a20a8900812e2b513217084607cb78004782e /dev-python/nose-exclude/nose-exclude-0.3.0.ebuild
parentdev-python/pytest: Version Bump (diff)
downloadgentoo-366587f522f9158cd7612877d42a807087b2fe1c.tar.gz
gentoo-366587f522f9158cd7612877d42a807087b2fe1c.tar.bz2
gentoo-366587f522f9158cd7612877d42a807087b2fe1c.zip
dev-python/nose-exclude: Version Bump
Fix HOMEPAGE Enable test for python2 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/nose-exclude/nose-exclude-0.3.0.ebuild')
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.3.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/nose-exclude/nose-exclude-0.3.0.ebuild b/dev-python/nose-exclude/nose-exclude-0.3.0.ebuild
index c3a90062bd4f..09afe293eb69 100644
--- a/dev-python/nose-exclude/nose-exclude-0.3.0.ebuild
+++ b/dev-python/nose-exclude/nose-exclude-0.3.0.ebuild
@@ -3,12 +3,13 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="Exclude specific directories from nosetests runs"
-HOMEPAGE="https://bitbucket.org/kgrandis/nose-exclude"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -17,9 +18,9 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-RESTRICT="test"
python_test() {
- # https://bitbucket.org/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+ # https://github.com/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+ python_is_python3 && return
esetup.py test
}