summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 10:00:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 10:29:27 +0100
commitf5689c04c75cab702ddbdd414ec6de83688a5aad (patch)
tree334c40cc5a8d89dc5d0b9c500c73f1998aa7ba62 /dev-python/nose2/nose2-0.11.0.ebuild
parentdev-python/hypothesis: Bump to 6.36.2 (diff)
downloadgentoo-f5689c04c75cab702ddbdd414ec6de83688a5aad.tar.gz
gentoo-f5689c04c75cab702ddbdd414ec6de83688a5aad.tar.bz2
gentoo-f5689c04c75cab702ddbdd414ec6de83688a5aad.zip
dev-python/nose2: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose2/nose2-0.11.0.ebuild')
-rw-r--r--dev-python/nose2/nose2-0.11.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/nose2/nose2-0.11.0.ebuild b/dev-python/nose2/nose2-0.11.0.ebuild
new file mode 100644
index 000000000000..3d1a41ca2bdf
--- /dev/null
+++ b/dev-python/nose2/nose2-0.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Next generation unittest with plugins"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}