summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-05 04:54:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-05 04:54:45 +0200
commitb63c5e14366bce130104fbe039fbc12260a22aba (patch)
tree8e8027942a17e71f24f27e03f7b215eafc1f0633 /dev-python/nose2
parentdev-python/xxhash: Bump to 3.4.1 (diff)
downloadgentoo-b63c5e14366bce130104fbe039fbc12260a22aba.tar.gz
gentoo-b63c5e14366bce130104fbe039fbc12260a22aba.tar.bz2
gentoo-b63c5e14366bce130104fbe039fbc12260a22aba.zip
dev-python/nose2: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.14.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index 66482a47c025..7033bfa282c5 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.13.0.gh.tar.gz 159435 BLAKE2B 33a0d395045933c41cd22c8c30a933fb0fc14a21abf5aa4af459687e28126b89f5aad4e57aa4b06a303c50581e785f38708c0071e9cfe37c609046310540c595 SHA512 d2f16eddab75cecd864005eee3d29159e2c83d843c79df73f65d6dfacab7c195ae9b5e6d059848689d6b71da89035df8eb73d277560c1967d732c1522b54bfc5
+DIST nose2-0.14.0.gh.tar.gz 159460 BLAKE2B c72f939f597eead3a5d8be995fc4ae1988a0c76f5599dc9e040780520055aa1002d2d93f35527e56f90609d2f4ef560161bbf695bb3751cac71007dfbd06c522 SHA512 ed6b245bc57b63b011883f42dbda8b2797504afa02a102c43f4e7d3c6cbfcf7e8babca23f9341c7681b75dae12c2d269ea65a583c18d4d15b999df081fc0247b
diff --git a/dev-python/nose2/nose2-0.14.0.ebuild b/dev-python/nose2/nose2-0.14.0.ebuild
new file mode 100644
index 000000000000..19ec968fbda6
--- /dev/null
+++ b/dev-python/nose2/nose2-0.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+SRC_URI="
+ https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}