summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-16 09:27:49 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-16 09:27:49 -0500
commitf5c55a16fa52ad0a2e6166c8420653baa938fa45 (patch)
tree6f6606f158da57074ff9a43fa5d000fff654aed2 /dev-python/nose2
parentdev-python/stormpath: remove version 2.1.6 (diff)
downloadgentoo-f5c55a16fa52ad0a2e6166c8420653baa938fa45.tar.gz
gentoo-f5c55a16fa52ad0a2e6166c8420653baa938fa45.tar.bz2
gentoo-f5c55a16fa52ad0a2e6166c8420653baa938fa45.zip
dev-python/nose2: add version 0.6.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.6.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index 50f33d19036a..ed86fec5707a 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1 +1,2 @@
DIST nose2-0.6.4.tar.gz 134636 SHA256 56831c4caa47e2939f555b33e2c44170c1fab4d13526af838d9d80bef9e091b6 SHA512 4161231ecf195a3c5172f8bea2002f9cf4d55ee4f976f512b1ae758ebe8389f41520594da7ad2b21cfbf998be388993281e126363d24ee00c948d6c57278333a WHIRLPOOL 2905a358ec07d67ff64882f73527044a6bfbd70cb11865ee274b91675c3939b7b018d8dceb667396afae9ed425c14bd6ae3317d97fc2e35931302e6965054c6f
+DIST nose2-0.6.5.tar.gz 134808 SHA256 13c00fd49fe2057688a68860f5de195e50ec85748f102346c74e7692b36d2c23 SHA512 fc84aa19d486ff1441dd43666182212e4a05b3be054f3c8967e36e624c08ee6eb10b01bba45b5f5dbbd38cfd057d53877e0bc0d9aba59b842688a5d4ec944b40 WHIRLPOOL b08589fe1b1467d11f31b702f6dad4c2212e7a47f370138a110ee109d0c078a38a137ef0b21afc6d8e718074c662d28ded8ce19423df4357ade771af3238d229
diff --git a/dev-python/nose2/nose2-0.6.5.ebuild b/dev-python/nose2/nose2-0.6.5.ebuild
new file mode 100644
index 000000000000..f83b33e63e77
--- /dev/null
+++ b/dev-python/nose2/nose2-0.6.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="nose2 is the next generation of nicer testing for Python"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${CDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cov-core-1.12[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}