summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 21:42:13 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 21:43:53 +0200
commit6c79c648e1863f863f169b41977c444881cba1b1 (patch)
treed43aa70c4939f363a733bfc3b9cd1c62df6c5e65 /dev-python/nototools/nototools-20180827.ebuild
parentdev-python/booleanOperations: New package needed for noto-emoji (diff)
downloadgentoo-6c79c648e1863f863f169b41977c444881cba1b1.tar.gz
gentoo-6c79c648e1863f863f169b41977c444881cba1b1.tar.bz2
gentoo-6c79c648e1863f863f169b41977c444881cba1b1.zip
dev-python/nototools: New package needed for noto-emoji
Bug: https://bugs.gentoo.org/616974 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/nototools/nototools-20180827.ebuild')
-rw-r--r--dev-python/nototools/nototools-20180827.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nototools/nototools-20180827.ebuild b/dev-python/nototools/nototools-20180827.ebuild
new file mode 100644
index 000000000000..ae273247db2c
--- /dev/null
+++ b/dev-python/nototools/nototools-20180827.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Doesn't work with python3 yet:
+# https://github.com/googlei18n/nototools/issues/472
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlei18n/nototools"
+
+COMMIT="40aa4936022295cf851bb62f09a070f63fc8f5ae"
+SRC_URI="https://github.com/googlei18n/nototools/archive/${COMMIT}.tar.gz#/nototools-${COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/backports-os[${PYTHON_USEDEP}]
+ dev-python/booleanOperations[${PYTHON_USEDEP}]
+ dev-python/defcon[${PYTHON_USEDEP}]
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ esetup.py test
+}