summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-09 09:41:38 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-09 09:41:56 +0200
commit58758c908b5e82f020d2b20d3ade5fbbc680cce4 (patch)
treed19dce36469a30f368706a2fb804e31223683545 /dev-python/nototools
parentdev-python/booleanOperations: Support python 3.10 (diff)
downloadgentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.tar.gz
gentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.tar.bz2
gentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.zip
dev-python/nototools: Bump to 0.2.16
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/nototools')
-rw-r--r--dev-python/nototools/Manifest1
-rw-r--r--dev-python/nototools/nototools-0.2.16.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nototools/Manifest b/dev-python/nototools/Manifest
index a578c99fee3d..5bb39fe9a6b1 100644
--- a/dev-python/nototools/Manifest
+++ b/dev-python/nototools/Manifest
@@ -1 +1,2 @@
DIST nototools-0.2.13.tar.gz 9574809 BLAKE2B 8c5f59721ed3294162d9578955f0493007fdcebe5aecb3364abf22add5cedb12de99c63064574ea84b553cf2547af2ac2203e68b4a380527695edd72cf05f6c7 SHA512 8e46ed8d5c683dd93a14890df059a86824fda7f39011570cb414a471c380ed5464cfbe2ee6c8b0c2819d35fabf51ed5495df4c49d5c562fed5467ac2bde135e6
+DIST nototools-0.2.16.tar.gz 9712796 BLAKE2B 654f449a00741dfa4a9b3b8c2a80d40907698098d1c4ee94363657d88b24fe1f26287af5e7795484846d394573a868ff82fa9a8c0a51b953325d6f6f97d7f7c8 SHA512 3c70c29f8411ae3eedc2738e0b2f42f9c0b675494bbdc107a8b43612fba08401c704ec94db63bb92aa1648b168f9e0d9e8139b8c61dc3b43973876d105324554
diff --git a/dev-python/nototools/nototools-0.2.16.ebuild b/dev-python/nototools/nototools-0.2.16.ebuild
new file mode 100644
index 000000000000..b6b05644a50d
--- /dev/null
+++ b/dev-python/nototools/nototools-0.2.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+MY_PN="notofonttools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlefonts/nototools"
+#SRC_URI="https://github.com/googlefonts/nototools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=media-gfx/scour-0.37
+ >=dev-python/booleanOperations-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/defcon-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Some tests weren't ported to python3 yet and lots of failures
+RESTRICT="test"
+
+distutils_enable_tests setup.py