summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2019-08-03 23:58:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-04 15:06:24 +0300
commit35a8771efd257f68ffccdbc53e92b91ad438dc8e (patch)
treece8ed005dbaea07fe852d3198c83834991b333c4 /dev-python/nuitka/nuitka-0.6.5.ebuild
parentmedia-sound/whipper: use non-deprecated pygobject (diff)
downloadgentoo-35a8771efd257f68ffccdbc53e92b91ad438dc8e.tar.gz
gentoo-35a8771efd257f68ffccdbc53e92b91ad438dc8e.tar.bz2
gentoo-35a8771efd257f68ffccdbc53e92b91ad438dc8e.zip
dev-python/nuitka: bump version to 0.6.5
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Package-Manager: Portage-2.3.69, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/12608 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/nuitka/nuitka-0.6.5.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-0.6.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-0.6.5.ebuild b/dev-python/nuitka/nuitka-0.6.5.ebuild
new file mode 100644
index 000000000000..ed2ba72a1c00
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7})
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/appdirs[${PYTHON_USEDEP}]
+ >dev-util/scons-3.0.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}