summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-06 23:22:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-07 00:07:20 +0100
commita00e29dec41047869f155c03c3ca2613ea8a7c6b (patch)
tree861e249319934fc97caa9323240f59395ea8a18e /dev-python/nuitka
parentdev-python/yamlpath: Bump to 3.6.4 (diff)
downloadgentoo-a00e29dec41047869f155c03c3ca2613ea8a7c6b.tar.gz
gentoo-a00e29dec41047869f155c03c3ca2613ea8a7c6b.tar.bz2
gentoo-a00e29dec41047869f155c03c3ca2613ea8a7c6b.zip
dev-python/nuitka: Bump to 0.6.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.18.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 60391a0882b2..2f850bc855bf 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-0.6.17.6.tar.gz 3148827 BLAKE2B 4c898cac6ae5934e45ecfd37222670d7665ad9f512ae4e7f4e94eb25d19cd434448dbdf188b74398c49eea3b26a393f4fabfddb879be4d2bd795fc1ae6a8538d SHA512 1e370b083861cc9953ab9b72c98dc81f9d6bbf97196abc69d8229ed2a87f2151101b825c8d34d3656cf3b1cc0cdcbbc5a4aa97fc1c32ce605b0535cbf2d3142f
DIST Nuitka-0.6.17.7.tar.gz 3150990 BLAKE2B 130c98e0499380591f3d3a4d6acabd396749624eca7a0ddcaa997e27ce0ae05d22230edb4fc7284b89dd3bfad1ac16092b7db5ae7c7b7e7c7a41c1f5a16ea8f3 SHA512 08f99cafbdedaca2df2967f452038a69827f291ab825c31231b434e80f56da0698b458f129c2639d2820257c7dc86e306b507742d4d695002d5a64ab8747cb3e
+DIST Nuitka-0.6.18.1.tar.gz 3688411 BLAKE2B 4ddc98cfb34ff825c628200a72c8cb671a1053c7085a542bf49c96617155c69424b1de924cf6fb7fdaf5a5a52049781f687c1cda909fe4309410296e79f34435 SHA512 3638e6c8dd25a19f69eec3bafed22d758a1ec6c15d0491f91d9c6e5570014b87f6efd6d8944a3e85ade314f49128af8cee15b745e26660cfc466fc22bba3e717
DIST Nuitka-0.6.18.tar.gz 3687825 BLAKE2B f2c5655c610083065cc205c0a92ff9c57edfc87a479592f435c3dd194e2d6d71ff0ee9866bc97f222b3936190a4420e7d69cf9413b5b2a5e9439448dda82004f SHA512 df4c81d890ce9c5dc24e648f65137d4bb91dcb92917859976a3400ace6c297f985cee4932b50cb3c2aedb2eaa806be7529a98a75a32fe3f59ec718ed3281003b
diff --git a/dev-python/nuitka/nuitka-0.6.18.1.ebuild b/dev-python/nuitka/nuitka-0.6.18.1.ebuild
new file mode 100644
index 000000000000..d42d1b9e532c
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.18.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}