summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-25 21:12:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-26 22:16:16 +0200
commit9afdf5d9a4f7e90b8bffed24b2d843ddc510261d (patch)
tree824b94e8615e74a220a4524b1676d7e04ed83710 /dev-python/numexpr
parentnet-misc/netifrc: bump, fixes #598078 (diff)
downloadgentoo-9afdf5d9a4f7e90b8bffed24b2d843ddc510261d.tar.gz
gentoo-9afdf5d9a4f7e90b8bffed24b2d843ddc510261d.tar.bz2
gentoo-9afdf5d9a4f7e90b8bffed24b2d843ddc510261d.zip
dev-python/numexpr: Version bump to 2.6.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.6.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index ad3b9cac0c39..87f2ee2ba2c2 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -2,3 +2,4 @@ DIST numexpr-2.4.3.tar.gz 85171 SHA256 3ae7191c89df40db6b0a8637a4dace7c5956bc910
DIST numexpr-2.4.4.tar.gz 87133 SHA256 dfa2fad1af040e93a8022fbe4437f2183bf80e5f64d466381ad589308a73565b SHA512 abc53f8aafb39e55b6b811c1f08c01eefca23c36fb9d20a82484ef658c8062ffe51d8841d6651f43fb7f8cea6420270623df6ba9f98a95a0f7a09e6ceef91b35 WHIRLPOOL 9ab19609189e866a11c03b0aeaa3b93124d8018d53e8dec641721eff39eb73c969c34c457209d63988361ffadef13a205ba5b71d19ad120e9f44313f42c7cd1b
DIST numexpr-2.4.6.tar.gz 87481 SHA256 052397670dc56d7845ff894cd7d858e4f115491ecd93bcc0eda5cb83990c5da3 SHA512 fb68e0e782fd9e9e3cef9288addc0dfc3b79dbf01f0e72422cda6d5effd0f1629a49f9e5b89dcd16fa904423e0e9c776f3f276b4817e83cc58029c90a8627096 WHIRLPOOL 485eb98636f1ee5e1efbc843b404a23f3495d1b6682de15b67275a9c4082c87a1550d1bb91a19a7942f10f2f137af4a6294aaed95d7fd746f2db45d7319b70ec
DIST numexpr-2.5.tar.gz 88347 SHA256 319cdf4e402177a1c8ed4972cffd09f523446f186d347b7c1974787cdabf0294 SHA512 32cc70a9dd8cec67d014056c98e798bdaef6338365366ebebd60fa5655dda2cdcb5df550c8afe87aa85e0c87ebada6ae695d125d8b605f32c368bde731ff2a6c WHIRLPOOL a48a887b324d9a904083621024fcdd6c5fcaa60577c9d76bf88bb370d844b75c409851e9f4a28aefce2a5a3f0420329c67f3d68e825c2525db1dd6aea2340bb1
+DIST numexpr-2.6.1.tar.gz 90819 SHA256 db2ee72f277b23c82d204189290ea4b792f9bd5b9d67744b045f8c2a8e929a06 SHA512 07c88b1788ecad2c59260e7a6a15dfc21d486462a8866091d157286e5ce3b5b77f5fdab401fd30e2a5e4880398af53641d557003497c7d3658421bfcff38c31c WHIRLPOOL ef77ff356f79d2171685aa1267a63dfbd89a120300dd970bb9768df611a734483e21f78d4b1b09c4f3a5943cbbb6e9b48f03191bd7738063df076c07b6663a49
diff --git a/dev-python/numexpr/numexpr-2.6.1.ebuild b/dev-python/numexpr/numexpr-2.6.1.ebuild
new file mode 100644
index 000000000000..81dfab2fdae5
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mkl"
+
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ mkl? ( sci-libs/mkl )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # TODO: mkl can be used but it fails for me
+ # only works with mkl in tree. newer mkl will use pkgconfig
+ if use mkl; then
+ use amd64 && local ext="_lp64"
+ cat > site.cfg <<- _EOF_ || die
+ [mkl]
+ library_dirs = ${MKLROOT}/lib/em64t
+ include_dirs = ${MKLROOT}/include
+ mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
+ mkl_intel_thread, mkl_core, iomp5
+ _EOF_
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS}"
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" \
+ -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
+ || die
+ pushd >/dev/null || die
+}