summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 17:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 17:47:11 +0200
commitf51ebaae33fd7d97ec0c2055f94c2b03584f3936 (patch)
treeb2914ff24001924ef4b49b4857330101f33f25c2 /dev-python/numexpr
parentdev-python/ensurepip-setuptools: Bump to 68.2.2 (diff)
downloadgentoo-f51ebaae33fd7d97ec0c2055f94c2b03584f3936.tar.gz
gentoo-f51ebaae33fd7d97ec0c2055f94c2b03584f3936.tar.bz2
gentoo-f51ebaae33fd7d97ec0c2055f94c2b03584f3936.zip
dev-python/numexpr: Bump to 2.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.8.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 9c158cceb466..0ab0df38dcea 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1,3 @@
DIST numexpr-2.8.4.gh.tar.gz 113594 BLAKE2B 65756e3a0755cd69b8586501d5026dc355f5263f852fedc4f59ecd1854576929bff702cc603c53c7230a5a0ad034a56c50db0bf2fbc2174b3f5272d3a03ffdc0 SHA512 e0a4eacb1a8721b9c2b4331f21e460fc3a1740a6a156eb43b31c495b17e191508f6d72375b8bd286a9be66ceaa1353f64f894deda0b4b29c3ac48c5b7c67cfa1
DIST numexpr-2.8.5.gh.tar.gz 117015 BLAKE2B edf0084806cde40c7aa002a34b462f62f5d3cc37bc698f0125c4997c897333fccfff7c0df8a2ab96c0d7cf97ba7cc5955266ece50611e56c513798a3fc1306d0 SHA512 e02e8249ec62c85da1730d0932bcaf15fa10ff5e0a2ff847014c8d00b94612d441a9b1af46331b15480e63cfeb0fc84e31804db075789f23575003b4d8d1da48
+DIST numexpr-2.8.6.gh.tar.gz 117693 BLAKE2B dcc02c5ac0a2fd73d731e570365fb78ee6948b3a6547cd59fd6a03275757810e4e064bd6a9ebadd6e2713674263ed1457fb6b42f46a13e1d751f9591875ea7c4 SHA512 50aa882d522b84d46d2b3790e853138f8f587e11c32376185edaa03a5cec84261cbd123913b7566102e911c88730c9fc926c82e122d0c2e6efd3625241079df5
diff --git a/dev-python/numexpr/numexpr-2.8.6.ebuild b/dev-python/numexpr/numexpr-2.8.6.ebuild
new file mode 100644
index 000000000000..27d778316ec8
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.8.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="
+ https://github.com/pydata/numexpr/
+ https://pypi.org/project/numexpr/
+"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+DEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test().wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}