summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-14 20:32:47 +0000
committerSam James <sam@gentoo.org>2022-01-14 20:32:47 +0000
commit6e99b3b25a0a1bdd5b706e494b4cedb044f101fe (patch)
treefa86e730c67ce91fe54716f8f8e1ad7ef59ce78b /dev-python/numpy/files
parentmedia-video/wireplumber: add patch references (diff)
downloadgentoo-6e99b3b25a0a1bdd5b706e494b4cedb044f101fe.tar.gz
gentoo-6e99b3b25a0a1bdd5b706e494b4cedb044f101fe.tar.bz2
gentoo-6e99b3b25a0a1bdd5b706e494b4cedb044f101fe.zip
dev-python/numpy: add 1.22.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/numpy/files')
-rw-r--r--dev-python/numpy/files/numpy-1.22.1-revert-setuptools-upper-bound.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/numpy/files/numpy-1.22.1-revert-setuptools-upper-bound.patch b/dev-python/numpy/files/numpy-1.22.1-revert-setuptools-upper-bound.patch
new file mode 100644
index 000000000000..a2bc9c939aea
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.22.1-revert-setuptools-upper-bound.patch
@@ -0,0 +1,22 @@
+Revert https://github.com/numpy/numpy/commit/eb6be7c4765665724cd12431bfefb050ba0f2d4b.
+
+See also:
+https://github.com/pypa/setuptools/issues/2372
+https://github.com/numpy/numpy/issues/20692
+
+In the ebuild, we're forcing SETUPTOOLS_USE_DISTUTILS=stdlib which uses
+the distutils version from within Python (which will be removed in 3.11)
+rather than the bundled-in-setuptools-60 version which breaks numpy.
+--- a/setup.py
++++ b/setup.py
+@@ -80,10 +80,6 @@ if os.path.exists('MANIFEST'):
+ # so that it is in sys.modules
+ import numpy.distutils.command.sdist
+ import setuptools
+-if int(setuptools.__version__.split('.')[0]) >= 60:
+- raise RuntimeError(
+- "Setuptools version is '{}', version < '60.0.0' is required. "
+- "See pyproject.toml".format(setuptools.__version__))
+
+ # Initialize cmdclass from versioneer
+ from numpy.distutils.core import numpy_cmdclass