summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-03-03 17:23:05 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-03 17:25:31 +0100
commit09f3824f30a37092664909b512043b0321e3d14d (patch)
treedc96c334da2fb3a93afb03d7c89ecd4256de4d99 /dev-python/numpy/numpy-1.16.1.ebuild
parentuse.stable.mask: mask USE=systemd on hppa, no stable keywords (diff)
downloadgentoo-09f3824f30a37092664909b512043b0321e3d14d.tar.gz
gentoo-09f3824f30a37092664909b512043b0321e3d14d.tar.bz2
gentoo-09f3824f30a37092664909b512043b0321e3d14d.zip
dev-python/numpy: re-add parallel make workaround for USE=-lapack
Bug: https://bugs.gentoo.org/660754 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/numpy/numpy-1.16.1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.16.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-1.16.1.ebuild b/dev-python/numpy/numpy-1.16.1.ebuild
index bf2f0cc9d3b7..ecb913628ef6 100644
--- a/dev-python/numpy/numpy-1.16.1.ebuild
+++ b/dev-python/numpy/numpy-1.16.1.ebuild
@@ -112,6 +112,8 @@ python_prepare_all() {
}
python_compile() {
+ use !lapack && export MAKEOPTS=-j1 #660754
+
local python_makeopts_jobs=""
python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
distutils-r1_python_compile \