summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-06-23 20:46:21 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-06-23 20:47:37 +0800
commitf5c71a4aa9615c8c14caa8e7076519ab2a4b9824 (patch)
treece334fbf49e2d2d1a60ec93ce0eea43f1611f945 /dev-python/numpy/numpy-1.16.1.ebuild
parentdev-util/strace: m68k stable wrt bug #686580 (diff)
downloadgentoo-f5c71a4aa9615c8c14caa8e7076519ab2a4b9824.tar.gz
gentoo-f5c71a4aa9615c8c14caa8e7076519ab2a4b9824.tar.bz2
gentoo-f5c71a4aa9615c8c14caa8e7076519ab2a4b9824.zip
dev-python/numpy: fix cblas detection.
Drop old ebuilds versionator eclass. Drop live ebuild. It has not been taken care of since numpy-1.9. Suggested-By: Zongyu Zhang <zzy2529420793@gmail.com> Closes: https://bugs.gentoo.org/647072 Closes: https://bugs.gentoo.org/688392 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/numpy/numpy-1.16.1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.16.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/numpy/numpy-1.16.1.ebuild b/dev-python/numpy/numpy-1.16.1.ebuild
index edcbf60858cc..1ec2abd0447f 100644
--- a/dev-python/numpy/numpy-1.16.1.ebuild
+++ b/dev-python/numpy/numpy-1.16.1.ebuild
@@ -70,10 +70,11 @@ pc_libs() {
python_prepare_all() {
if use lapack; then
append-ldflags "$($(tc-getPKG_CONFIG) --libs-only-other cblas lapack)"
+ local incdir="${EPREFIX}"/usr/include
local libdir="${EPREFIX}"/usr/$(get_libdir)
cat >> site.cfg <<-EOF || die
[blas]
- include_dirs = $(pc_incdir cblas)
+ include_dirs = $(pc_incdir cblas):${incdir}
library_dirs = $(pc_libdir cblas blas):${libdir}
blas_libs = $(pc_libs cblas blas)
[lapack]