summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-02-15 11:37:58 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-02-15 11:38:14 +0900
commit24fe73b1ff793e8a9170b0c2f71335d8bd20a258 (patch)
treef9986d25127c3a2ec1ad5238edf593e68db2b223 /dev-python/numpy
parentnet-print/cups: Switch to using pidfile, bug 551544 (diff)
downloadgentoo-24fe73b1ff793e8a9170b0c2f71335d8bd20a258.tar.gz
gentoo-24fe73b1ff793e8a9170b0c2f71335d8bd20a258.tar.bz2
gentoo-24fe73b1ff793e8a9170b0c2f71335d8bd20a258.zip
dev-python/numpy: record include_dirs of blas
We specify blas in site.cfg, which could have non-standard include dirs. sci-libs/scikits_learn, for example, relies on this information to find cblas. Upstream: https://github.com/numpy/numpy/pull/8619 Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/files/numpy-1.11.2-blas_rec_inc_dir.patch24
-rw-r--r--dev-python/numpy/numpy-1.11.2-r1.ebuild2
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-python/numpy/files/numpy-1.11.2-blas_rec_inc_dir.patch b/dev-python/numpy/files/numpy-1.11.2-blas_rec_inc_dir.patch
new file mode 100644
index 000000000000..9a934cc2a40a
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.11.2-blas_rec_inc_dir.patch
@@ -0,0 +1,24 @@
+commit 61e9159569a601315b67c30b6e26bbb2149c0bfa
+Author: Benda Xu <heroxbd@gentoo.org>
+Date: Wed Feb 15 11:17:05 2017 +0900
+
+ BUG: blas_info should record include_dirs
+
+ blas specified in site.cfg could have non-standard include dirs.
+ It should be read and saved in distutils/__config__.py
+
+PR: https://github.com/numpy/numpy/pull/8619
+
+diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
+index b8520ac..0fba865 100644
+--- a/numpy/distutils/system_info.py
++++ b/numpy/distutils/system_info.py
+@@ -1667,6 +1667,8 @@ class blas_info(system_info):
+ info = self.check_libs(lib_dirs, blas_libs, [])
+ if info is None:
+ return
++ else:
++ info['include_dirs'] = self.get_include_dirs()
+ if platform.system() == 'Windows':
+ # The check for windows is needed because has_cblas uses the
+ # same compiler that was used to compile Python and msvc is
diff --git a/dev-python/numpy/numpy-1.11.2-r1.ebuild b/dev-python/numpy/numpy-1.11.2-r1.ebuild
index 87da9bf152b4..803872d8167a 100644
--- a/dev-python/numpy/numpy-1.11.2-r1.ebuild
+++ b/dev-python/numpy/numpy-1.11.2-r1.ebuild
@@ -37,7 +37,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-1.11.1-no-hardcode-blas.patch
-
+ "${FILESDIR}"/${PN}-1.11.2-blas_rec_inc_dir.patch
# This has been fixed upstream but no new release yet
# https://github.com/numpy/numpy/commit/5d0ce36e5be134bb5ead03cab1edeaa60fa355aa
"${FILESDIR}"/${P}-import-module-fix.patch