summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-16 17:21:39 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:38:01 -0600
commit1aa416c8c77d032ccca51f7655c4dc3c757e80fc (patch)
treec2c8dcee78619019eff76f2bf56b3012b5863819 /dev-python/oauthlib/oauthlib-2.0.6.ebuild
parentapp-office/libreoffice: Drop 5.4 stable branch (diff)
downloadgentoo-1aa416c8c77d032ccca51f7655c4dc3c757e80fc.tar.gz
gentoo-1aa416c8c77d032ccca51f7655c4dc3c757e80fc.tar.bz2
gentoo-1aa416c8c77d032ccca51f7655c4dc3c757e80fc.zip
dev-python/oauthlib: 2.0.6 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/oauthlib/oauthlib-2.0.6.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-2.0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/oauthlib/oauthlib-2.0.6.ebuild b/dev-python/oauthlib/oauthlib-2.0.6.ebuild
new file mode 100644
index 000000000000..75343c46ee84
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-2.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib https://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) )
+ "
+
+python_test() {
+ nosetests -v || die "tests failed under ${EPYTHON}"
+}