summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/odfpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/Manifest2
-rw-r--r--dev-python/odfpy/files/odfpy-0.9.4-tests.patch32
-rw-r--r--dev-python/odfpy/metadata.xml8
-rw-r--r--dev-python/odfpy/odfpy-0.9.6-r1.ebuild33
-rw-r--r--dev-python/odfpy/odfpy-1.3.1.ebuild41
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/odfpy/Manifest b/dev-python/odfpy/Manifest
new file mode 100644
index 000000000000..a4c901be8c9b
--- /dev/null
+++ b/dev-python/odfpy/Manifest
@@ -0,0 +1,2 @@
+DIST odfpy-0.9.6.tar.gz 452061 SHA256 907f62853858913bc3d5b00e4be4f4e5d56ab3f0d51125a54e949824b560f0bf SHA512 6e49e956426695984d634c2409129741b84d093886fe8012dc17196e20abff77bb486c986e497b0f35642ad0de60a8bbf3cf07352d85ea509cab7da9f3fa470b WHIRLPOOL 11625e99a500eb9e6c13b1c1cb19486689accbb2f8dc6f93a858496ba5f60a1513a89302bce24c1603ef0d46a17bca1126a40c4532f9fafb2cab3b0263c1acd8
+DIST odfpy-1.3.1.tar.gz 469339 SHA256 0292500fbe716fd261bfef71ddf231fd9bc913d2b0a1ced91a2488bdf3c9fcea SHA512 a730e3763069d91ec5f613e6222efbb46cbc32c6ddf962f574b86f6dbaa728491ec3f1ca6707f5d5227bb5968cd6f75a66f40576372ea72b794886f219c46ab1 WHIRLPOOL 843f311e50a9a4575f2d929baee65610e723a90b9af09ea1c52f22770a87fa3e8f71c35c94d248fc2372b9a0128a802f1ae54dba6638f411c9ff0a3de83b1cef
diff --git a/dev-python/odfpy/files/odfpy-0.9.4-tests.patch b/dev-python/odfpy/files/odfpy-0.9.4-tests.patch
new file mode 100644
index 000000000000..1c0be00af5a8
--- /dev/null
+++ b/dev-python/odfpy/files/odfpy-0.9.4-tests.patch
@@ -0,0 +1,32 @@
+--- tests/testxmlgen.py
++++ tests/testxmlgen.py
+@@ -20,6 +20,7 @@
+
+ import xml.sax, xml.sax.saxutils
+ import StringIO
++import sys
+ import unittest
+
+ class MyGen(xml.sax.saxutils.XMLGenerator):
+@@ -70,14 +71,16 @@
+ <a:greetings xmlns:a="http://example.com/ns">
+ <a:greet xml:lang="en">Hello world</a:greet>
+ </a:greetings>"""
+- parser.feed(testcontent)
+- parser.close()
+- expectedresult="""<?xml version="1.0" encoding="utf-8"?>
++ if sys.version_info < (2, 7):
++ self.assertRaises(KeyError, parser.feed, testcontent)
++ else:
++ parser.feed(testcontent)
++ parser.close()
++ expectedresult="""<?xml version="1.0" encoding="utf-8"?>
+ <a:greetings xmlns:a="http://example.com/ns">
+ <a:greet xml:lang="en">Hello world</a:greet>
+ </a:greetings>"""
+- self.assertEqual( outfp.getvalue(), expectedresult)
+-# self.assertRaises(KeyError, parser.feed, testcontent)
++ self.assertEqual( outfp.getvalue(), expectedresult)
+
+ def test_myxml(self):
+ """ Test that my patch works """
diff --git a/dev-python/odfpy/metadata.xml b/dev-python/odfpy/metadata.xml
new file mode 100644
index 000000000000..70933e33efcb
--- /dev/null
+++ b/dev-python/odfpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">odfpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/odfpy/odfpy-0.9.6-r1.ebuild b/dev-python/odfpy/odfpy-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..a599cc03b7e1
--- /dev/null
+++ b/dev-python/odfpy/odfpy-0.9.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home http://pypi.python.org/pypi/odfpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.4-tests.patch" )
+
+python_test() {
+ local exit_status=0 test
+ for test in tests/test*.py; do
+ einfo "Running ${test} ..."
+ "${PYTHON}" "${test}"
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ return ${exit_status}
+}
diff --git a/dev-python/odfpy/odfpy-1.3.1.ebuild b/dev-python/odfpy/odfpy-1.3.1.ebuild
new file mode 100644
index 000000000000..042a082f014e
--- /dev/null
+++ b/dev-python/odfpy/odfpy-1.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Classifier: Programming Language :: Python :: 2 :: Only
+# py3 fails one test, pypy anpother.
+# Notes on page of home repo reports support of python3.
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home http://pypi.python.org/pypi/odfpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# Tarball missing required folder to build docs in html.
+
+python_test() {
+ # Known single fail under python3 suspected to be caused in python3 itself
+ # https://github.com/eea/odfpy/issues/21
+
+ local exit_status=0 test
+ for test in tests/test*.py; do
+ einfo "Running ${test} ..."
+ "${PYTHON}" ${test}
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ return ${exit_status}
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}