summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-03-12 13:16:50 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-03-12 13:28:36 +0100
commit7868514002cd478cd3bd78ff4fcc9db8646cebda (patch)
treeb4f7ee74ecf15ae8093849b4299a2d6ecf338283 /dev-python/openpyxl/openpyxl-2.3.3.ebuild
parentdev-python/openpyxl: remove old versions (diff)
downloadgentoo-7868514002cd478cd3bd78ff4fcc9db8646cebda.tar.gz
gentoo-7868514002cd478cd3bd78ff4fcc9db8646cebda.tar.bz2
gentoo-7868514002cd478cd3bd78ff4fcc9db8646cebda.zip
dev-python/openpyxl: version bump to 2.3.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/openpyxl/openpyxl-2.3.3.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-2.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-2.3.3.ebuild b/dev-python/openpyxl/openpyxl-2.3.3.ebuild
new file mode 100644
index 000000000000..2d6375f7d9b9
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="http://openpyxl.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+# tests aren't contained in tarball
+RESTRICT="test"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}