summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-10-18 21:23:29 +0300
committerMichał Górny <mgorny@gentoo.org>2019-11-09 18:23:43 +0100
commit84c7d250e3b3eed3093e4a7c082d36f99e44281c (patch)
tree31d96a6bb89e9da5164681f5cb6a468c6da1125d /dev-python/openpyxl/openpyxl-2.6.4.ebuild
parentnet-dns/avahi: don't create an empty "/run" directory (diff)
downloadgentoo-84c7d250e3b3eed3093e4a7c082d36f99e44281c.tar.gz
gentoo-84c7d250e3b3eed3093e4a7c082d36f99e44281c.tar.bz2
gentoo-84c7d250e3b3eed3093e4a7c082d36f99e44281c.zip
dev-python/openpyxl: bump v2.6.4
last version supporting python2 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl/openpyxl-2.6.4.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-2.6.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-2.6.4.ebuild b/dev-python/openpyxl/openpyxl-2.6.4.ebuild
new file mode 100644
index 000000000000..a737ad853545
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.6.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+# https://bitbucket.org/openpyxl/openpyxl/issues/1308/include-tests-in-pypi-tarballs
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ pytest -vv || die "Testing failed with ${EPYTHON}"
+}