summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-16 18:04:41 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-16 18:05:07 -0500
commitf8c0bf57edbd1d0dea965335d5277d68a34970be (patch)
tree78e6f73de75909198d84de9b71afa622d2ad4fc1 /dev-python/os-client-config/os-client-config-1.6.3.ebuild
parentsci-biology/emboss: amd64 stable wrt bug #529038 (diff)
downloadgentoo-f8c0bf57edbd1d0dea965335d5277d68a34970be.tar.gz
gentoo-f8c0bf57edbd1d0dea965335d5277d68a34970be.tar.bz2
gentoo-f8c0bf57edbd1d0dea965335d5277d68a34970be.zip
dev-python/os-client-config: add version 1.6.3
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/os-client-config/os-client-config-1.6.3.ebuild')
-rw-r--r--dev-python/os-client-config/os-client-config-1.6.3.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/os-client-config/os-client-config-1.6.3.ebuild b/dev-python/os-client-config/os-client-config-1.6.3.ebuild
new file mode 100644
index 000000000000..1ef8b3f3bd17
--- /dev/null
+++ b/dev-python/os-client-config/os-client-config-1.6.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Client Configuation Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/extras[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+ <dev-python/oslotest-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/test_get_all_clouds.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}