summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:59:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:24 -0500
commitd88e445532fb1b3826d9a1e97f3dd6b9369bc0c8 (patch)
tree7ff3551fbf2d48941ae453696cd8df6f3ab07f71 /dev-python/os-testr
parentdev-python/lazr-config: add DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-d88e445532fb1b3826d9a1e97f3dd6b9369bc0c8.tar.gz
gentoo-d88e445532fb1b3826d9a1e97f3dd6b9369bc0c8.tar.bz2
gentoo-d88e445532fb1b3826d9a1e97f3dd6b9369bc0c8.zip
dev-python/os-testr: 2.0.0 bump
Closes: https://bugs.gentoo.org/748378 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-testr')
-rw-r--r--dev-python/os-testr/Manifest1
-rw-r--r--dev-python/os-testr/os-testr-2.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/os-testr/Manifest b/dev-python/os-testr/Manifest
index f1580f3fdadd..a8d2dea221e2 100644
--- a/dev-python/os-testr/Manifest
+++ b/dev-python/os-testr/Manifest
@@ -1 +1,2 @@
DIST os-testr-1.0.0.tar.gz 43382 BLAKE2B c5a9b22700ce40acff8ceeb796d9fa0b840038cd285d80630b16c3399e8c188d87dc54de653d06a2c0918185e9ffd4695747f59d4d42eb158f9ea18bc361963d SHA512 2189abc76840d935d63635874ebdae7c325b392bc24a52e07e1046b47a17be6fd97ba17dc5593ae7a1e2bff9c5b0dbbfd8ade8a2382dce2223ee4047b3483cec
+DIST os-testr-2.0.0.tar.gz 46787 BLAKE2B ff1b862c24d1f88d0794ad9139a0d57e6da5d57404ad3c659a18d84316b0cb603ec5c3455cf89fd12183dabc060537f6b077cd09a9fe1f785c6cd56fc0c596b4 SHA512 0ee6a144a75f7742aaf6859161f7918fb908a6783180a022a8698ce4dffeac50bf453c208b47ec784687d88a55739fff822483f404f246f222c24245ed6845ea
diff --git a/dev-python/os-testr/os-testr-2.0.0.ebuild b/dev-python/os-testr/os-testr-2.0.0.ebuild
new file mode 100644
index 000000000000..b81454b8ef0e
--- /dev/null
+++ b/dev-python/os-testr/os-testr-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/os-testr/ https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}