summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-30 15:54:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-30 16:06:40 -0500
commitb40eee97dd3e89202987a96d78cea6061027849d (patch)
treef2f6ad2f614bfe2da857969dc2b5fdd8b71d5497 /dev-python/os-traits/os-traits-0.3.3.ebuild
parentdev-python/os-vif: 1.7.0 bup (diff)
downloadgentoo-b40eee97dd3e89202987a96d78cea6061027849d.tar.gz
gentoo-b40eee97dd3e89202987a96d78cea6061027849d.tar.bz2
gentoo-b40eee97dd3e89202987a96d78cea6061027849d.zip
dev-python/os-traits: adding for pike
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/os-traits/os-traits-0.3.3.ebuild')
-rw-r--r--dev-python/os-traits/os-traits-0.3.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/os-traits/os-traits-0.3.3.ebuild b/dev-python/os-traits/os-traits-0.3.3.ebuild
new file mode 100644
index 000000000000..52e4b51e566b
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}